背景:
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
族谱通常由系谱树来表示。你的工作是统计那些没有孩子的家庭成员总数。
输入格式:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format: ID K ID[1] ID[2] … ID[K] where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.The input ends with N being 0. That case must NOT be processed.
每个输入文件包含一个测试用例。每一种情况都以包含以下内容:第一行有一个正整数N(0<N<100),它代表节点的总数,还有一个正整数M,代表不是叶节点的节点总数;然后接着有M行,每一行的格式都是 ID k ID[1] ID[2]…ID[K],其中第一个ID是一个两位数,代表一个给定的非叶节点,K是它的子节点的数量,后面是它的全部子节点的两位数ID序列。为了简单起见,规定根节点的ID为01。
输出格式:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
对于每个测试用例,你应该从根节点开始,计算每一层(同辈)的没有孩子的家庭成员总数。结果必须在一行中输出,用空格隔开,并且在每行的末尾不能有额外的空格。示例示例表示一棵只有2个节点的树,其中01是根节点,02是唯一的子节点。因此在根01层上,有0个叶节点;下一层,有1个叶节点。所以应该在一行中输出0 1。
输入样例:
2 1
01 1 02
输出样例:
0 1
思路:
使用深度优先遍历 算法,但要注意,必须额外设置一个变量来弄清节点是否是叶节点。
C实现代码:
#include <stdio.h>
int N,M,a,b,map[101][101],book[101],num[101];
const int max = 99999999;
void dfs(int cur,int dep)
{
int x = 0;
for(int i = 1;i <= N;i++)
if(book[i] == 0 && map[cur][i] != max)
{
book[i] = 1;
x = 1;
dfs(i,dep + 1);
book[i] = 0;
}
if(x == 0)
num[dep] += 1;
return;
}
int main()
{
int c;
for(int i = 1;i <= 100;i++)
for(int j = 1;j <= 100;j++)
if(i != j)
map[i][j] = max;
scanf("%d%d",&N,&M);
for(int i = 1;i <= M;i++)
{
scanf("%d%d",&a,&c);
for(int j = 1;j <= c;j++)
{
scanf("%d",&b);
map[a][b] = 1;
map[b][a] = 1;
}
}
book[1] = 1;
dfs(1,1);
for(int i = 1;i <= 100;i++)
if(num[i] != 0)
c = i;
for(int i = 1;i <= c;i++)
if(i != c)
printf("%d ",num[i]);
else if(i == c)
printf("%d",num[i]);
return 0;
}
|