1008 Elevator (20 分)
The highest building in our city has only one elevator. A request list is made up with?N?positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Each input file contains one test case. Each case contains a positive integer?N, followed by?N?positive numbers. All the numbers in the input are less than 100.
Output Specification:
For each test case, print the total time on a single line.
3 2 3 1
Sample Output:
41
?我们城市最高的建筑只有一部电梯。请求列表由?N?正数。数字表示电梯将按指定顺序在哪些楼层停止。将电梯向上移动一层需要 6 秒钟,向下移动一层需要 4 秒钟。电梯将在每个站点停留5秒钟。?
?对于给定的请求列表,您将计算完成列表中的请求所花费的总时间。电梯在开始时位于0楼,在满足要求时不必返回一楼。?
?输入规格:?
?每个输入文件包含一个测试用例。每个事例都包含一个正整数?N?其次?N?正数。输入中的所有数字都小于 100。?
?输出规格:?
?对于每个测试用例,在一行上打印总时间。?
?示例输入:?
?示例输出:?
?
41
#include <iostream>
using namespace std;
int main(int argc, char** argv)
{
int n,a1=0,a2,sum=0;
cin>>n;
cin>>a1;
sum=a1*6+5;
for(int i=1;i<n;i++)
{
cin>>a2;
if(a2>a1)
{
sum+=(a2-a1)*6+5;
}
else
{
sum+=(a1-a2)*4+5;
}
a1=a2;
}
cout<<sum;
return 0;
}
?
|