IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 游戏开发 -> [巴什博弈][找规律]A Childhood Game LightOJ1020 -> 正文阅读

[游戏开发][巴什博弈][找规律]A Childhood Game LightOJ1020

Alice and Bob are playing a game with marbles; you may have played this game in childhood. The game is playing by alternating turns. In each turn a player can take exactly one or two marbles.

Both Alice and Bob know the number of marbles initially. Now the game can be started by any one. But the winning condition depends on the player who starts it. If Alice starts first, then the player who takes the last marble loses the game. If Bob starts first, then the player who takes the last marble wins the game.

Now you are given the initial number of marbles and the name of the player who starts first. Then you have to find the winner of the game if both of them play optimally.

Input

Input starts with an integer?T (≤ 10000), denoting the number of test cases.

Each case contains an integer?n (1 ≤ n < 231)
and the name of the player who starts first.

Output

For each case, print the case number and the name of the winning player.

Sample Input

3
1 Alice
2 Alice
3 Bob

Sample Output

Case 1: Bob
Case 2: Alice
Case 3: Alice

题意: Alice和Bob取石子,一开始有n颗石子,每轮游戏开始前确定谁先手,若Alice先手,谁取到最后一个石子谁输,若Bob先手,谁取到最后一个石子谁赢。

分析:?巴什博弈,如果没看出来找找规律也可以做出来。对于取到最后一个石子会赢的情况,如果对方出现n%(m+1)=0这种情况,则己方必胜,对于取到最后一个石子会输的情况,相等于取到第n-1个石子的人会赢,转化为上一种情况,如果对方出现(n-1)%(m+1)=0这种情况,则己方必胜。其中m是可选择范围[1, m]。

具体代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

signed main()
{
	int T;
	cin >> T;
	for(int i = 1; i <= T; i++)
	{
		printf("Case %d: ", i);
		int n;
		char name[10];
		scanf("%d%s", &n, name);
		if(*name == 'A')
		{
			//轮到Alice时剩2或3或5或6颗必胜,剩1或4或7颗必输 
			if((n-1) % 3 == 0)
				puts("Bob");
			else
				puts("Alice");
		}
		else
		{
			//轮到Bob时如果剩3或6或9颗必输,剩1或2或4或5颗必胜 
			if(n % 3 == 0)
				puts("Alice");
			else
				puts("Bob"); 
		}
	} 
    return 0;
}

  游戏开发 最新文章
6、英飞凌-AURIX-TC3XX: PWM实验之使用 GT
泛型自动装箱
CubeMax添加Rtthread操作系统 组件STM32F10
python多线程编程:如何优雅地关闭线程
数据类型隐式转换导致的阻塞
WebAPi实现多文件上传,并附带参数
from origin ‘null‘ has been blocked by
UE4 蓝图调用C++函数(附带项目工程)
Unity学习笔记(一)结构体的简单理解与应用
【Memory As a Programming Concept in C a
上一篇文章      下一篇文章      查看所有文章
加:2021-10-07 14:07:54  更:2021-10-07 14:09:18 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/28 2:50:04-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码