IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 游戏开发 -> A1016 Phone Bills (25 分)PAT甲级真题(C++)题解【排序】 -> 正文阅读

[游戏开发]A1016 Phone Bills (25 分)PAT甲级真题(C++)题解【排序】

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number?N?(≤1000), followed by?N?lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word?on-line?or?off-line.

For each test case, all dates will be within a single month. Each?on-line?record is paired with the chronologically next record for the same customer provided it is an?off-line?record. Any?on-line?records that are not paired with an?off-line?record are ignored, as are?off-line?records not paired with an?on-line?record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

没有特别复杂的数据结构,主要是思想上要理清楚,代码中为了方便比较和统计时间,全部转换为以分钟为单位进行表示

代码如下:

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
struct record
{
    int dd,hh,mm;
    int t;//换算为分钟后的总时间
    string tag;//on,off
};

bool cmp(record a,record b)
{
    return a.t<b.t;
}

int n;//记录个数
int price[24];
map<string,vector<record>>M;//每一个用户的记录

int main()
{
    for(int i=0;i<24;i++)scanf("%d",&price[i]);
    int month;//根据题目要求,所有记录都是在一个月内的
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        string name,tag;
        int dd,hh,mm;
        char c;//用来吃掉输入时的“:”
        cin>>name>>month>>c>>dd>>c>>hh>>c>>mm>>tag;
        record temp;
        temp.dd=dd;
        temp.hh=hh;
        temp.mm=mm;
        temp.tag=tag;
        temp.t=dd*1440+hh*60+mm;//换算成用分钟表示
        M[name].emplace_back(temp);//存入该用户的记录容器中
    }
    //开始匹配
    for(auto it=M.begin();it!=M.end();++it)
    {
        auto V=it->second;//first获取的是name,second获取记录的容器
        sort(V.begin(),V.end(),cmp);//将所有记录按时间顺序进行排序
        double total=0;//月度费用
        for(int i=0;i<V.size();)
        {
            if(i+1<V.size()&&V[i].tag>V[i+1].tag)//匹配到了on-off
            {
                if(!total)//第一次匹配到的时候total为0,此时输出用户名
                {
                    cout<<it->first;
                    printf(" %02d\n",month);
                }
                int time1=V[i].t;
                int time2=V[i+1].t;
                double part=0;
                for(int time=time1;time<time2;time++)
                {
                    part+=price[time%1440/60];
                    //价格是按每分钟来算的,我们就一分钟一分钟地加,time%1440先算出一天当中占多少分钟,再/60求出是哪个小时区间
                }
                printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",V[i].dd,V[i].hh,V[i].mm,V[i+1].dd,V[i+1].hh,V[i+1].mm,V[i+1].t-V[i].t,part/100);
                total+=part;
                i+=2;
            }
            else{
                i+=1;
            }
        }
        if(total)printf("Total amount: $%.2f\n",total/100);
    }
    return 0;
}

运行结果如下:

?

  游戏开发 最新文章
6、英飞凌-AURIX-TC3XX: PWM实验之使用 GT
泛型自动装箱
CubeMax添加Rtthread操作系统 组件STM32F10
python多线程编程:如何优雅地关闭线程
数据类型隐式转换导致的阻塞
WebAPi实现多文件上传,并附带参数
from origin ‘null‘ has been blocked by
UE4 蓝图调用C++函数(附带项目工程)
Unity学习笔记(一)结构体的简单理解与应用
【Memory As a Programming Concept in C a
上一篇文章      下一篇文章      查看所有文章
加:2022-03-30 18:59:49  更:2022-03-30 19:03:42 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2025年1日历 -2025/1/16 17:35:18-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码