IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 游戏开发 -> ENSP:小型企业网络拓扑设计 -> 正文阅读

[游戏开发]ENSP:小型企业网络拓扑设计

功能:内网与外网使用静态路由、浮动路由互通;

有单独的dhcp服务器,使用核心层的两台交换机作为中继代理为有线终端动态下发ip地址;

实现有线与无线的互访,但无线用户不能访问财务部;

利用vrrp+mstp实现冗余分担、LSW5作为实例1的根桥,LSW6作为实例2的根桥。..........

配置:

LSW1

vlan batch 10
#
stp region-configuration
 region-name dc
 instance 1 vlan 10 20 30
 instance 2 vlan 40 50 60
 active region-configuration
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 10
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

? LSW2

vlan batch 20
#
stp region-configuration
 region-name dc
 instance 1 vlan 10 20 30
 instance 2 vlan 40 50 60
 active region-configuration
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 20
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

LSW3

vlan batch 30
#
acl number 3001
 rule 5 deny ip source 192.168.50.0 0.0.0.255 destination 192.168.30.0 0.0.0.255
#
stp region-configuration
 region-name dc
 instance 1 vlan 10 20 30
 instance 2 vlan 40 50 60
 active region-configuration
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 30
traffic-filter outbound acl 3001
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

LSW4

?

vlan batch 40
#
stp region-configuration
 region-name dc
 instance 1 vlan 10 20 30
 instance 2 vlan 40 50 60
 active region-configuration
#
interface Ethernet0/0/1
 port link-type access
 port default vlan 40
#
interface Ethernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface Ethernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

LSW5

vlan batch 10 20 30 40 50 60 201
#
dhcp enable
#
stp instance 1 root primary
stp instance 2 root secondary
#
stp region-configuration
 region-name dc
 instance 1 vlan 10 20 30
 instance 2 vlan 40 50 60
 active region-configuration
#
drop-profile default

#
interface Vlanif10
 ip address 192.168.10.1 255.255.255.0
 vrrp vrid 10 virtual-ip 192.168.10.254
 vrrp vrid 10 priority 120
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif20
 ip address 192.168.20.1 255.255.255.0
 vrrp vrid 20 virtual-ip 192.168.20.254
 vrrp vrid 20 priority 120
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif30
 ip address 192.168.30.1 255.255.255.0
 vrrp vrid 30 virtual-ip 192.168.30.254
 vrrp vrid 30 priority 120
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif40
 ip address 192.168.40.1 255.255.255.0
 vrrp vrid 40 virtual-ip 192.168.40.254
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif50
 ip address 192.168.50.1 255.255.255.0
 vrrp vrid 50 virtual-ip 192.168.50.254
#
interface Vlanif60
 ip address 192.168.60.252 255.255.255.0
 vrrp vrid 60 virtual-ip 192.168.60.254
#
interface Vlanif201
 ip address 192.168.201.1 255.255.255.0
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 201
#
interface GigabitEthernet0/0/6
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
interface GigabitEthernet0/0/23
 eth-trunk 1
#
interface GigabitEthernet0/0/24
 eth-trunk 1
#
interface NULL0
#
ospf 1
 area 0.0.0.0
  network 192.168.0.0 0.0.255.255
#
ip route-static 0.0.0.0 0.0.0.0 192.168.201.2
port-group 1
 group-member GigabitEthernet0/0/1
 group-member GigabitEthernet0/0/2
 group-member GigabitEthernet0/0/3
 group-member GigabitEthernet0/0/4


LSW6

#
vlan batch 10 20 30 40 50 to 51 60 202
#
stp instance 1 root secondary
stp instance 2 root primary
#
dhcp enable
#
stp region-configuration
 region-name dc
 instance 1 vlan 10 20 30
 instance 2 vlan 40 50 60
 active region-configuration
#
interface Vlanif10
 ip address 192.168.10.2 255.255.255.0
 vrrp vrid 10 virtual-ip 192.168.10.254
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif20
 ip address 192.168.20.2 255.255.255.0
 vrrp vrid 20 virtual-ip 192.168.20.254
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif30
 ip address 192.168.30.2 255.255.255.0
 vrrp vrid 30 virtual-ip 192.168.30.254
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif40
 ip address 192.168.40.2 255.255.255.0
 vrrp vrid 40 virtual-ip 192.168.40.254
 vrrp vrid 40 priority 120
 dhcp select relay
 dhcp relay server-ip 192.168.60.1
#
interface Vlanif50
 ip address 192.168.50.2 255.255.255.0
 vrrp vrid 50 virtual-ip 192.168.50.254
 vrrp vrid 50 priority 120
#
interface Vlanif60
 ip address 192.168.60.253 255.255.255.0
 vrrp vrid 60 virtual-ip 192.168.60.254
 vrrp vrid 60 priority 120
#
interface Vlanif202
 ip address 192.168.202.1 255.255.255.0
#
interface Eth-Trunk1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 202
#
interface GigabitEthernet0/0/6
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/7
 port link-type trunk
 port trunk allow-pass vlan 50 to 51
#
interface GigabitEthernet0/0/8
 port link-type trunk
 port trunk pvid vlan 51
 port trunk allow-pass vlan 50 to 51
#
interface GigabitEthernet0/0/23
 eth-trunk 1
#
interface GigabitEthernet0/0/24
 eth-trunk 1
#
interface NULL0
#
ospf 1
 area 0.0.0.0
  network 192.168.0.0 0.0.255.255
#
ip route-static 0.0.0.0 0.0.0.0 192.168.202.2
#
port-group 1
 group-member GigabitEthernet0/0/1
 group-member GigabitEthernet0/0/2
 group-member GigabitEthernet0/0/3
 group-member GigabitEthernet0/0/4

AC配置与这这篇大致相同,可参考https://blog.csdn.net/weixin_45921302/article/details/126974565?spm=1001.2014.3001.5501

LSW7

vlan batch 60
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 60
#
interface GigabitEthernet0/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/4
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094

DHCP服务器

dhcp enable
#
ip pool vlan10
 gateway-list 192.168.10.254 
 network 192.168.10.0 mask 255.255.255.0 
 dns-list 8.8.8.8 
#
ip pool vlan20
 gateway-list 192.168.20.254 
 network 192.168.20.0 mask 255.255.255.0 
 dns-list 8.8.8.8 
#
ip pool vlan30
 gateway-list 192.168.30.254 
 network 192.168.30.0 mask 255.255.255.0 
 dns-list 8.8.8.8 
#
ip pool vlan40
 gateway-list 192.168.40.24 
 network 192.168.40.0 mask 255.255.255.0 
 dns-list 8.8.8.8 
#

interface GigabitEthernet0/0/0
 ip address 192.168.60.1 255.255.255.0 
 dhcp select global
#
ip route-static 0.0.0.0 0.0.0.0 192.168.60.254

AR1

Interface GigabitEthernet0/0/0
 ip address 10.1.1.1 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 10.1.2.1 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 192.168.201.2 255.255.255.0 
#
interface GigabitEthernet4/0/0
 ip address 192.168.202.2 255.255.255.0 
#
ospf 1 
 area 0.0.0.0 
  network 10.1.1.0 0.0.0.255 
  network 10.1.2.0 0.0.0.255 
  network 192.168.201.0 0.0.0.255 
  network 192.168.202.0 0.0.0.255 
#
ip route-static 0.0.0.0 0.0.0.0 10.1.1.2
ip route-static 0.0.0.0 0.0.0.0 10.1.2.2 preference 65

AR3

interface GigabitEthernet0/0/0
 ip address 10.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 10.1.2.2 255.255.255.0 
#
interface GigabitEthernet0/0/2
 ip address 20.1.1.1 255.255.255.0 
#
ip route-static 30.1.1.0 255.255.255.0 20.1.1.2
ip route-static 192.168.0.0 255.255.0.0 10.1.1.1
ip route-static 192.168.0.0 255.255.0.0 10.1.2.1 preference 65

AR5

#
interface GigabitEthernet0/0/0
 ip address 20.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 30.1.1.1 255.255.255.0 
#
ip route-static 192.168.0.0 255.255.0.0 20.1.1.1

其他用户

?验证

有线终端获取地址

?无线终端获取地址

?有线用户访问其他用户

?无线访问有线

?

?其他用户访问有线用户

?无线不能访问财务部

?浮动路由,当有线访问其他用户,走的是10.1.1.0这条路

当宕掉10.1.1.0这条路,走的是10.1.2.0这条路

?

?

?配置实验的拓扑文件获取:链接:https://pan.baidu.com/s/1BAsJw_dsu1wUXrxlL7kOvQ?
提取码:ab12

  游戏开发 最新文章
6、英飞凌-AURIX-TC3XX: PWM实验之使用 GT
泛型自动装箱
CubeMax添加Rtthread操作系统 组件STM32F10
python多线程编程:如何优雅地关闭线程
数据类型隐式转换导致的阻塞
WebAPi实现多文件上传,并附带参数
from origin ‘null‘ has been blocked by
UE4 蓝图调用C++函数(附带项目工程)
Unity学习笔记(一)结构体的简单理解与应用
【Memory As a Programming Concept in C a
上一篇文章      下一篇文章      查看所有文章
加:2022-12-25 11:39:00  更:2022-12-25 11:40:27 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/8 2:17:10-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码