IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 系统运维 -> 2021ccpc网络赛重赛1011 - Jumping Monkey(并查集 + 树的深度)(nb题) -> 正文阅读

[系统运维]2021ccpc网络赛重赛1011 - Jumping Monkey(并查集 + 树的深度)(nb题)

Problem Description

There is a tree with n nodes and n?1 edges that make all nodes connected. Each node i has a distinct weight ai. A monkey is jumping on the tree. In one jump, the monkey can jump from node u to node v if and only if av is the greatest of all nodes on the shortest path from node u to node v. The monkey will stop jumping once no more nodes can be reached.

For each integer k∈[1,n], calculate the maximum number of nodes the monkey can reach if he starts from node k.

Input

The first line of the input contains an integer T (1≤T≤1e4), representing the number of test cases.

The first line of each test case contains an integer n (1≤n≤1e5), representing the number of nodes.

Each of the following n?1 lines contains two integers u,v (1≤u,v≤n), representing an edge connecting node u and node v. It is guaranteed that the input will form a tree.

The next line contains n distinct integers a1,a2,…,an (1≤ai≤1e9), representing the weight of each node.

It is guaranteed that the sum of n over all test cases does not exceed 8×1e5.

Output

For each test case, output n lines. The k-th line contains an integer representing the answer when the monkey starts from node k.

Sample Input

2
3
1 2
2 3
1 2 3
5
1 2
1 3
2 4
2 5
1 4 2 5 3

Sample Output

3
2
1
4
2
3
1
3

题意:

给你一棵树,然后猴子在树上跳,猴子能从 i 点跳到 j 点当且仅当从 i 到 j 的路径中 j 的权重最大,现在让你求出从每一个点出发所能经过的最多节点数

题解:

就是并查集,这个集合内的点可以说是随便跳的,就是在这个集合里的答案就是他是第几大数,然后做法就是按权值从小到大排序,然后枚举节点u,u就作为与u相连的联通块的根,这是为什么呢,是因为现在的联通块里面的节点的权值是都比 u 的权值小的,然后咱们一会儿就是从权值最大的点进行dfs的,所以咱们需要连一条单向边,表示联通块里的所有元素都能到这个点,而且跳到这个点之后还可以跳到连向 u 的点,所以说这类似于反向建边了,然后就反向建边反向递推就出来了,可能比较难想(对于我这种菜鸡来说)哈哈哈,下面请看代码吧

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int N = 100010;
typedef pair<int,int> PII;
typedef long long  LL;
vector<int> G[N],NG[N];
int pa[N];
int find(int x){
 if(x != pa[x]) pa[x] = find(pa[x]);
 return pa[x];
}
PII a[N];
bool st[N];
int ans[N];
void dfs(int u,int fa){
 for(auto j : NG[u]){
  if(j == fa) continue;
  ans[j] = ans[u] + 1;
  dfs(j,u);
 }
}
int main(){
 int T;
 scanf("%d",&T);
 while(T--){
  int n;
  scanf("%d",&n);
  for(int i=1;i<=n;i++) G[i].clear() , NG[i].clear() , pa[i] = i , st[i] = false;
  for(int i=1;i<n;i++){
   int a,b;
   scanf("%d%d",&a,&b);
   G[a].push_back(b);
   G[b].push_back(a);
  }
  for(int i=1;i<=n;i++){
   scanf("%d",&a[i].first);
   a[i].second = i;
  }
  sort(a+1,a+1+n);
  for(int i=1;i<=n;i++){
   int u = a[i].second;
   for(auto j : G[u]){
    if(!st[j]) continue;
    int v = find(j);
    pa[v] = u;
    NG[u].push_back(v);
   }
   st[u] = true;
  }                
  ans[a[n].second] = 1;
  dfs(a[n].second,0);
  for(int i=1;i<=n;i++) printf("%d\n",ans[i]);
 }
 return 0;
}
  系统运维 最新文章
配置小型公司网络WLAN基本业务(AC通过三层
如何在交付运维过程中建立风险底线意识,提
快速传输大文件,怎么通过网络传大文件给对
从游戏服务端角度分析移动同步(状态同步)
MySQL使用MyCat实现分库分表
如何用DWDM射频光纤技术实现200公里外的站点
国内顺畅下载k8s.gcr.io的镜像
自动化测试appium
ctfshow ssrf
Linux操作系统学习之实用指令(Centos7/8均
上一篇文章      下一篇文章      查看所有文章
加:2021-10-12 23:53:40  更:2021-10-12 23:54:48 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/15 18:50:39-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码