华为模拟器实现wlan二层组网
拓扑图 路由器:
interface GigabitEthernet0/0/1
ip address 10.1.30.1 255.255.255.0
ip route-static 10.1.20.0 255.255.255.0 10.1.30.2
三层交换机
vlan batch 10 20 30
dhcp enable
interface GigabitEthernet0/0/1 与路由器链接
port link-type access
port default vlan 30
interface GigabitEthernet0/0/2 与AC链接
port link-type trunk
port trunk allow-pass vlan 10
interface GigabitEthernet0/0/3 与二层交换机链接
port link-type trunk
port trunk allow-pass vlan 10
interface Vlanif20
ip address 10.1.20.1 255.255.255.0
dhcp select interface 此地址池用作ap为终端分配的地址
验证三层交换机到路由器的连通性
二层交换机
interface Ethernet0/0/1 与ap链接的接口
port link-type trunk
port trunk pvid vlan 10
port trunk allow-pass vlan 10 20
interface Ethernet0/0/2 与ap链接的接口
port link-type trunk
port trunk pvid vlan 10
port trunk allow-pass vlan 10 20
interface Ethernet0/0/3
port link-type trunk
port trunk allow-pass vlan 10 20
AC控制器
vlan 10
interface Vlanif10
ip address 10.1.10.1 255.255.255.0 此地址也是ap的管理地址
dhcp select interface 用于给ap分配地址
capwap source ip-address 10.1.10.1 用于建立和ap链接的隧道
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10
wlan
ap auth-mode no-auth 配置ap上线认证模式无不认证,此时ap会找到ac,并在ac上线。
display ap all
验证ap是否上线 可以看到ap已经获取到地址并且在ac上注册上线了。
下面就是为AP创建参数
wlan
ap auth-mode mac-auth ap上线后,再将认证方式改为mac认证,防止非法ap接入。
regulatory-domain-profile name huawei 配置域模板
country-code cn
ap-group name huawei 配置ap组
regulatory-domain-profile huawei 将域模板应用到ap组中
ap-id 0 每一个ap的id都是唯一的
ap-name ap1
ap-group huawei 将ap加入到ap组中
ap-id 1
ap-name ap2
ap-group huawei
配置安全模板,即wifi的密码和加密方式。
security-profile name huawei
security wpa-wpa2 psk pass-phrase a1234567 aes
配置ssid模板,即为WiFi起个名字
ssid-profile name huawei
ssid huawei
配置vap模板,相当于包含了WiFi的所有参数
vap-profile name huawei
service-vlan vlan-id 20 ap发射的信号都是vlan20,即终端获取的IP地址是vlan20地址池的地址。
ssid-profile huawei
security-profile huawei
forward-mode direct-forward
将vap模板应用到ap组中,相当于所有的ap发射的信号都有了参数,也可以应用到某个ap上。
ap-group name huawei
vap-profile huawei wlan 1 radio all 为ap开启信号
查看验证:在AC上查看WiFi名为huawei的信息。 效果图:终端都能获取IP地址,也可以和路由器连通
要点:
- ap发送的dhcp广播包是携带vlan10的tag的,通过二层交换机和三层交换机一直广播到AC,然后由AC回应为其分配IP地址。(注意广播包的路径要打通)
- 此时ap只是获取到IP地址,并不会在AC上注册上线,需要配置AP的认证方式。
|