?1,R5为ISP,只能进行IP地址配置;其所有地址均配为公有IP地址
首先,我们需要先创建拓扑模型,其次对每个网段和环回进行IP地址的规划
?
?然后对各个路由器进行IP配置
首先对各个接口配置IP
[r1-GigabitEthernet0/0/0]ip add 192.168.1.1 24
[r1-GigabitEthernet0/0/0]int s 4/0/0
[r2-GigabitEthernet0/0/0]ip add 192.168.2.1 24
[r2-Serial4/0/0]ip add 15.0.0.1 24
[r3-GigabitEthernet0/0/0]ip add 192.168.3.1 24
[r3-Serial4/0/0]ip add 20.0.0.1 24
[r4-GigabitEthernet0/0/0]ip add 192.168.4.1 24
[r4-GigabitEthernet0/0/1]ip add 25.0.0.1 24
[isp-Serial3/0/1]ip add 10.0.0.2 24
[isp-Serial4/0/1]ip add 15.0.0.2 24
[isp-Serial3/0/0]ip add 20.0.0.2 24
[isp-GigabitEthernet0/0/0]ip add 25.0.0.2 24
[isp-LoopBack0]ip add 5.5.5.1 24
然后对除isp之外的路由器写缺省路由,使得除私网外可通信
[r1]ip route-static 0.0.0.0 0 10.0.0.2
[r2]ip route-static 0.0.0.0 0 15.0.0.2
[r3]ip route-static 0.0.0.0 0 20.0.0.2
[r4]ip route-static 0.0.0.0 0 25.0.0.2
2,R1和R5间使用PPP的PAP认证,R5为主认证方;R2于R5之间使用PPP的chap认证,R5为主认证方; R3于R5之间使用HDLC封装。
R1和R5间使用PPP的PAP认证,R5为主认证方;
此时需要在认证方r5进行以下配置
1,在AAA中申请用户名和密码
[isp-aaa]local-user admin password cipher 12345
[isp-aaa]local-user admin service-type ppp
2,在接口做PAP认证
[isp-Serial3/0/1]ppp authentication-mode pap
在被认证方r1进行以下配置
[r1-Serial4/0/0]ppp pap local-user admin password cipher 12345
注意,PPP会话是一次性会话,会话一旦建立,再配置认证将不生效,再下次会话建立时 才生效
所以我们此时可以重新关闭接口,然后重启,此时如果仍然可以ping通证明认证成功?
此时便认证成功
R2于R5之间使用PPP的chap认证,R5为主认证方;
对主认证方进行以下配置
1,在AAA中申请用户名和密码
[isp-aaa]local-user admin password cipher 12345
[isp-aaa]local-user admin service-type ppp
2,在接口做PAP认证
[isp-Serial4/0/1]ppp authentication-mode chap
对于被认证方进行以下操作
[r2-Serial4/0/0]ppp chap user admin
[r2-Serial4/0/0]ppp chap password cipher 12345
还是跟上面一样此时并不能看出是否认证成功,仍然需要关闭接口,并且重启
[r2-Serial4/0/0]shutdown
[r2-Serial4/0/0]undo shutdown
?
R3于R5之间使用HDLC封装
只需要将两个接口改成HDLC
[r3-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
[isp-Serial3/0/0]link-protocol hdlc
3,R1/R2/R3构建一个MGRE环境,R1为中心站点;R1、R4间为点到点的GRE。
R1/R2/R3构建一个MGRE环境,R1为中心站点;
首先创建隧道,然后设定的虚拟网段为192.168.5.0
首先对中心r1进行配置
1,创建隧道接口
[r1]int Tunnel 0/0/0
2,隧道接口配置IP地址
[r1-Tunnel0/0/0]ip add 192.168.5.1 24
3,定义封装方式?
[r1-Tunnel0/0/0]tunnel-protocol gre p2mp
4,定义封装的源IP?
[r1-Tunnel0/0/0]source 10.0.0.1
5,创建NHRP域
[r1-Tunnel0/0/0]nhrp network-id 100
然后对r2,r3进行配置
对r2的配置
1,创建隧道接口
[r2]int Tunnel 0/0/0
2,隧道接口配置IP地址
[r1-Tunnel0/0/0]ip add 192.168.5.2 24
3,定义封装方式?
[r1-Tunnel0/0/0]tunnel-protocol gre p2mp
4,定义封装的源IP?
[r1-Tunnel0/0/0]source s 4/0/0
5,加入NHRP域
[r2-Tunnel0/0/0]nhrp network-id 100
6,找中心上报映射信息
[r2-Tunnel0/0/0]nhrp entry 192.168.5.1 10.0.0.1 register
对r3的配置
1,创建隧道接口
[r3]int Tunnel 0/0/0
2,隧道接口配置IP地址
[r3-Tunnel0/0/0]ip add 192.168.5.3 24
3,定义封装方式?
[r3-Tunnel0/0/0]tunnel-protocol gre p2mp
4,定义封装的源IP?
[r3-Tunnel0/0/0]source s 4/0/0
5,加入NHRP域
[r3-Tunnel0/0/0]nhrp network-id 100
6,找中心上报映射信息
[r3-Tunnel0/0/0]nhrp entry 192.168.5.1 10.0.0.1 register
此时以查看隧道接口和物理接口映射关系表
?
R1、R4间为点到点的GRE。
另外创建一条隧道网段为192.168.6.0
然后对r1进行以下配置
1,创建隧道接口
[R1]interface Tunnel 0/0/1
2,隧道接口配置IP地址
[r1-Tunnel0/0/1]ip add 192.168.6.1 24
3,定义封装方式
[r1-Tunnel0/0/1]tunnel-protocol gre
4,定义封装内容
[r1-Tunnel0/0/1]source 10.0.0.1
[r1-Tunnel0/0/1]description 25.0.0.1
对r4进行以下操作
1,创建隧道接口
[R4]interface Tunnel 0/0/1
2,隧道接口配置IP地址
[r4-Tunnel0/0/1]ip add 192.168.6.2 24
3,定义封装方式
[r4-Tunnel0/0/1]tunnel-protocol gre
4,定义封装内容
[r4-Tunnel0/0/1]source 25.0.0.1
[r4-Tunnel0/0/1]description 10.0.0.1
4,整个私有网络基于RIP全网可达
对各个路由器进行以下操作
[r1]rip
[r1-rip-1]v 2
[r1-rip-1]network 192.168.1.0
[r1-rip-1]network 192.168.5.0
[r1-rip-1]network 192.168.6.0
[r2]rip
[r2-rip-1]v 2
[r2-rip-1]network 192.168.2.0
[r2-rip-1]network 192.168.5.0
[r3]rip
[r3-rip-1]v 2
[r3-rip-1]network 192.168.3.0
[r3-rip-1]network 192.168.5.0
[r4]rip
[r4-rip-1]v 2
[r4-rip-1]network 192.168.4.0
[r4-rip-1]network 192.168.6.0
此时可以查看路由表
?
?
?
?有以上四图可知,只有r1通过rip获得了各个网段的路由,而其他路由器并未获得
原因是:MGRE环境是一种类似于NBMA的环境,不支持组播
解决方法:在中心上开启伪广播
[r1-Tunnel0/0/0]nhrp entry multicast dynamic
开启之后我们可以发现r2,r3只有一条中心的路由
原因:rip的水平分割
解决:关闭水平分割即可
[r1-Tunnel0/0/0]undo rip split-horizon
此时私有网路便通了
?
? 5,所有Pc设置私有IP为源IP,可以访问R5环回
对r1进行配置
[r1]acl 2000
[r1-acl-basic-2000]
[r1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[r1-acl-basic-2000]
[r1-acl-basic-2000]q
[r1]
[r1]int s 4/0/0
[r1-Serial4/0/0]nat outbound 2000
对r2进行配置?
[r2]acl 2000
[r2-acl-basic-2000]
[r2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[r2-acl-basic-2000]q
[r2]int s 4/0/0
[r2-Serial4/0/0]nat outbound 2000
对r3进行配置
[r3]acl 2000
[r3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[r3-acl-basic-2000]q
[r3]interface Serial 4/0/0
[r3-Serial4/0/0]
[r3-Serial4/0/0]nat outbound 2000
?
?
?对r4进行配置
[r4]acl 2000
[r4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[r4-acl-basic-2000]q
[r4]int g 0/0/1
[r4-GigabitEthernet0/0/1]nat outbound 2000
[r4-GigabitEthernet0/0/1]
?
?
?此时实验结束
|