项目七 路由器的广域网HDLC封装
? ? ? ? 信科公司为了使公司网络中相连的路由器处于保密、安全状态,避免外界干扰,决定配置路由器的HDLC封装,网络拓扑图如图3-23所示。?
?配置路由器广域网HDLC封装的具体操作如下:?
步骤1? ?? 配置路由器接口的IP地址,如表3-7所示。
表3-7? 路由器接口的IP地址?
路由器 | 接口 | IP地址 | Router0 | S0/0/0(DCE) | 192.168.1.1/24 | Router1 | S0/0/0(DTE) | 192.168.1.2/24 |
步骤2???配置Router0,代码如下?
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#encapsulation hdlc
Router(config-if)#clock rate 64000
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#ex
步骤3???配置Router1,代码如下?
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#encapsulation hdlc
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
Router(config-if)#ex
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
步骤4???测试网络连通性,代码如下?
Router#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/7 ms
Router#
任务八 路由器的PPP封装?
信科公司为了实现与ISP之间连接的安全性,采用了PPP协议对通信链路进行封装,网络拓扑图如图3-23所示,实现的具体操作如下:
步骤1????配置路由器接口的IP地址,如表3-7所示。?
表3-7? 路由器接口的IP地址?
路由器 | 接口 | IP地址 | Router0 | S0/0/0(DCE) | 192.168.1.1/24 | Router1 | S0/0/0(DTE) | 192.168.1.2/24 |
步骤2???配置Router0,代码如下?
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#en
Router(config-if)#encapsulation ppp
Router(config-if)#cl
Router(config-if)#clock ra
Router(config-if)#clock rate 64000
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#^Z
Router#
?步骤3???配置Router1,代码如下
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#en
Router(config-if)#encapsulation ppp
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
^Z
Router#
步骤4????测试网络连通性,代码如下?
Router#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/5 ms
任务九 路由器的广域网PPP封装PAP验证
? ? ? ?信科公司为了满足不断增长的业务需求,申请了专线接入,公司的客户端路由器与ISP进行链路协商时要验证身份,现在需要配置路由器保证链路建立并保证通信安全。
? ? ? ?为了实现与ISP之间连接的安全性,信科公司采用了PPP协议对通信链路进行封装,并且在通信链路建立完毕后,启用了PPP会话密码验证协议——PAP,网络拓扑图如图3-23所示。广域网PPP封装PAP的相关配置如表3-8所示。
表3-8? PPP封装PAP验证的基本配置
路由器 | 参数 | RouterA | 接口:S0/0/0 | IP地址:192.168.1.1 | 账号:RouterA | 密码:888A | RouterB | 接口:S0/0/0 | IP地址:192.168.1.2 | 账号:RouterB | 密码:888B |
配置路由器广域网PPP封装并进行PAP验证的具体操作如下:?
步骤1???配置Router0的S0/0/0端口IP,代码如下?
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
Router(config-if)#ex
步骤2???配置Router1的S0/0/0端口IP,代码如下??
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ex
?步骤3?? 将Router0命名为RouterA,代码如下??
Router(config)#ho RouterA
??步骤4?? 将Router1命名为RouterB,代码如下
Router(config)#ho RouterB
?步骤5?? 在router0配置,为路由器1设置一个用户名和口令,代码如下:
RouterA(config)#username RouterB password 888B
?步骤6?? 在router1配置,为路由器0设置一个用户名和口令,代码如下:
RouterB(config)#username RouterA password 888A
?步骤7?? 在router0配置,进入S0/0/0端口,进行PPP协议封装,并设置授权为PAP登录,代码如下:
RouterA(config)#int s0/0/0
RouterA(config-if)#encapsulation ppp
RouterA(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
RouterA(config-if)#ppp authentication pap
?步骤8?? 在router1配置,进入S0/0/0端口,进行PPP协议封装,并设置授权为PAP登录,代码如下:
RouterB(config)#int s0/0/0
RouterB(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
RouterB(config-if)#encapsulation ppp
RouterB(config-if)#ppp authentication pap
??步骤9?? 在router0配置,发送PAP登录的用户名和密码,代码如下:
RouterA(config-if)#ppp pap sent-username RouterA password 888A
RouterA(config-if)#
?步骤10?? 在router1配置,发送PAP登录的用户名和密码,代码如下:
RouterB(config-if)#ppp pap sent-username RouterB password 888B
??步骤11?? 在router0上进行连通性测试,代码如下:
RouterA#p 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/10 ms
RouterA#
?任务十?路由器的广域网PPP封装CHAP验证
? ? ? ?信科公司为了满足不断增长的业务需求,申请了专线接入,信科公司为了实现与ISP之间连接的安全性,采用了PPP协议对链路进行封装并采用PAP验证。
? ? ? 由于PAP在验证用户身份时信息以明文传输,这样,在验证过程中很可能被第三方窃取验证信息,公司不希望出现此现象,提出了更高的安全性要求。因此网络管理员决定采用PPP协议中的CHAP认证协议;CHAP认证协议在验证过程中采用加密验证,因此能更好地保证网络的安全,网络拓扑图如图3-23所示。PPP封装CHAP验证的基本配置如表3-9所示。
表3-9? PPP封装CHAP验证的基本配置
路由器 | 参数 | Router0 | 接口:S0/0/0 | IP地址:192.168.1.1 | 账号:RouterA | 密码:CH888 | Router1 | 接口:S0/0/0 | IP地址:192.168.1.2 | 账号:RouterB | 密码:CH888 |
配置路由器广域网PPP封装CHAP验证的具体操作如下:?
步骤1???配置Router0的S0/0/0端口IP,代码如下??
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#clo
Router(config-if)#clock rate 64000
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
步骤2???配置Router1的S0/0/0端口IP,代码如下??
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
?步骤3?? 将Router0命名为RouterA,并为路由器1设置一个用户名和口令,代码如下:
Router(config-if)#ex
Router(config)#ho RouterA
RouterA(config)#user
RouterA(config)#username RouterB password CH888
步骤4?将Router1命名为RouterB,并为路由器0设置一个用户名和口令,代码如下:
Router(config-if)#ex
Router(config)#ho RouterB
RouterB(config)#use
RouterB(config)#username RouterA pass
RouterB(config)#username RouterA password CH888
?步骤5?? 在router0配置,进入S0/0/0端口,进行PPP协议封装,并设置授权为CHAP登录,代码如下:
RouterA(config)#int s0/0/0
RouterA(config-if)#encapsulation ppp
RouterA(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
RouterA(config-if)#ppp authentication chap
RouterA(config-if)#
?步骤6?? 在router1配置,进入S0/0/0端口,进行PPP协议封装,并设置授权为CHAP登录,代码如下:
RouterB(config)#int s0/0/0
RouterB(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
RouterB(config-if)#encapsulation ppp
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
RouterB(config-if)#ppp authentication chap
RouterB(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
?步骤7?? 在router0上进行连通性测试,代码如下:
?(连通性测试需要在特权模式下进行~~~~)
RouterA#p 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/9 ms
RouterA#
任务十一? 利用动态NAT实现局域网访问互联网
? ? ? ?信科公司根据业务需要从ISP处申请到了一条专线,同时专线配有一个固定IP:202.168.2.1。现在公司希望企业内部的所有主机都能访问外网。
? ? ? 由于公司申请的网络专线只提供了一个公网地址,而公司内部又有大量的主机需要连接Internet,因此,工程师决定采用NAT技术,通过NAT地址转换技术实现公司内部全体上网。本任务网络拓扑图如图3-24所示。
?
?图3-24? 网络拓扑图
?利用动态NAPT实现局域网访问互联网的具体操作如下:
步骤1???根据前面任务所讲内容和表3-10配置路由器接口和计算机的IP地址,并进行连通性测试。
?表3-10? 路由器和计算机的IP地址
设备 | 接口 | IP地址 | 网关 | RouterA | S0/2(DCE) | 192.168.1.1/24 | | F0/0 | 192.168.0.1/24 | RouterB | S0/1(DTE) | 192.168.1.2/24 | | F0/0 | 192.168.2.1/24 | PC1 | | 192.168.0.3/24 | 192.168.0.1 | 外网SERVER | | 192.168.2.2/24 | 192.168.2.1 |
(1)设置各个端口IP地址
路由器IP设置指令:
1)router 0
?
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#ip add 192.168.0.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#ex
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#ex
?2)router 1端口指令:
?
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config-if)#ex
Router(config)#int f0/0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#ex
Router(config)#ex
3)PC和服务器设置IP
?
?
步骤2???本任务在Router0上做地址转换,将192.168.0.0/24转换成192.168.1.10~192.168.1.20之间的地址,并且做端口的地址复用,代码如下:
Router(config)#ip access-list standard 1
Router(config-std-nacl)#permit 192.168.0.0 0.0.0.255
Router(config-std-nacl)#ex
Router(config)#ip nat pool overld 192.168.1.10 192.168.1.20 netmask 255.255.255.0
Router(config)#ip nat inside source list 1 pool overld
Router(config)#int f0/0
Router(config-if)#ip nat inside
Router(config-if)#ex
Router(config)#int s0/0/0
Router(config-if)#ip nat outside
Router(config-if)#ex
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.2
Router(config)#ex
Router#
?
?步骤3????查看Router1的路由表,代码如下:
Router#sh ip route
?
?!注意:并没有到192.168.0.0 的路由
?
步骤4???在计算机PC0上用Ping命令测试网络,如图3-25所示。?
?
图3-25? 测试网络?
?
步骤5????查看地址转换表,代码如下:?
?
Router#sh ip nat translations
?
?
|