软件开发教程 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试
游戏开发 网络协议 系统运维 HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程
C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
 
   -> JavaScript知识库 -> vue项目中安装less-loader依赖包过程中出现的错误 -> 正文阅读

[JavaScript知识库]vue项目中安装less-loader依赖包过程中出现的错误

1、 可视化面板安装less-loader

用vue脚手架创建的项目默认没有安装less-loader的依赖,要使用less语法,就要安装less-loader相关的工具。

尝试用可视化面板安装less-loader依赖,安装后没有在可视化面板中找到该依赖。为了确认该依赖是否成功安装,去到项目中node_modules目录下寻找less-loader依赖,并未找到。

2、终端安装less-loader报错

2.1 问题描述

2.2 原因分析

安装命令输入错误

 install Usage of the '--dev' option is deprecated. Use '--include=dev' instead
 // "--dev"选项的安装用法已经弃用,使用“--include=dev”代替

3、安装less-loader后提示“this.getOptions is not a function”

3.1 问题描述

安装less-loader后出现新的错误提示

3.2 问题分析

通过查阅CSDN得知,可能是less-loader版本过高,卸载后重新安装7.0版本

// 卸载
npm uninstall --save less-loader
// 安装
npm install -D less-loader@7.x

4、参考文献

参考文章1:less-loader版本问题
参考文章2:sass-loader版本问题

  JavaScript知识库 最新文章
Vue2学习计划一:Vue初体验
Vue中路由表单缓存(keep-alive)
项目中的富文本编辑器该如何选择?
个人学习记录 - NodeJs Express 创建基础项
Vue开发笔记
typescript——前言和基础环境配置
Vue关于swiper轮播图组件的小细节
Vite创建Vue3.0项目
前端数据可视化之Echarts初体验
使用vue-route下的next({ ...to replace: t
上一篇文章      下一篇文章      查看所有文章
加:2021-07-17 12:34:11  更:2021-07-17 12:34:13 
 
360图书馆 购物 三丰科技 阅读网 日历 万年历 2021年7日历 -2021/7/27 3:34:29-
图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  软件开发教程